Welcome Guest [Log In] [Register]
Posted ImageWelcome to the all new Geo Metro Forum. We hope you enjoy your visit.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are features you can't use and images you can't see. Registration is simple, fast, and completely free. If you're already a member please log in to your account to access all of our features:

Join our community!




Username:   Password:
Add Reply
Engine diagnostic circuit 92 Metro; Check engine light will not flash codes
Topic Started: Dec 5 2010, 05:14 PM (904 Views)
Bill Parisian
New Member
[ *  * ]
I just bought a 92 Metro that was running poorly. I new it was a valve/cam problem before I bought it. The CHECK ENGINE LIGHT was not on. I changed the head, runs better, still no check engine light. I cleaned the throttle body coolant port and changed the sensor, Runs better no more smoking/flooding out, changed air charge sensor, not much change. I tried to check diagnostic codes and the check engine light comes on but no flashes. Any Idea what to do? :'(
Offline Profile Quote Post Goto Top
 
MR Bill
Member Avatar


Welcome to the forum

Bill
Offline Profile Quote Post Goto Top
 
GeoStalker
Member Avatar
Geo Stalker

If there's nothing wrong, you should be getting a one dash pause two dash signal (1-2). That means all clear. Did you put an extra fuse in the spare port in the fuse box?
Offline Profile Quote Post Goto Top
 
Bill Parisian
New Member
[ *  * ]
No I didn't know about putting a fuse in, can you leave it in or do you take it out after diagnostics?
I know it should read code 12 if everything is ok but I am new to this diagnostics I am old school give me a 62 Nova 4 cyl any day.
Offline Profile Quote Post Goto Top
 
Jittney
Anchorage 92 XFi

Take the fuse out after testing and put it back on the side with the other spares. :)
Offline Profile Quote Post Goto Top
 
Bill Parisian
New Member
[ *  * ]
Ok that worked but all I get is code 12. My problems are still there they are posted on the diagnostics page.
Offline Profile Quote Post Goto Top
 
liszabailey
Fresh Fish
[ * ]
Hi have you check the fuse if they are properly connected :gamerz and did you check all of the geo metro parts? have tried asking it on where did you bought it?.... :hmm :hmm :hmm :hmm
Edited by liszabailey, Dec 16 2010, 02:10 AM.
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Engine Tech & Diagnostics · Next Topic »
Add Reply