Welcome Guest [Log In] [Register]
Posted ImageWelcome to the all new Geo Metro Forum. We hope you enjoy your visit.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are features you can't use and images you can't see. Registration is simple, fast, and completely free. If you're already a member please log in to your account to access all of our features:

Join our community!




Username:   Password:
Add Reply
Project 94 RHD Metro; How can I be wrong... if I'm always right?
Topic Started: Aug 19 2012, 06:09 PM (49,860 Views)
94RHDRollerskate
Member Avatar
Forum Stud Muffin

Geo Glenn
Jun 24 2013, 02:25 AM
94RHDRollerskate
Jun 23 2013, 11:03 PM
.
Did a compression test tonight, and not too thrilled with the results: 107-105-150

.

:ermm: That sucks.


.
Yeah, I guess the auto trans isn't the only reason she's a bit slow off the line. :smackface

.
Offline Profile Quote Post Goto Top
 
snowfish
Member Avatar
Basic GearHead

94RHDRollerskate
Jun 23 2013, 11:03 PM
.
Did a compression test tonight, and not too thrilled with the results: 107-105-150

.
Tell me you forgot to hold wide open throttle! :'(
Offline Profile Quote Post Goto Top
 
Coche Blanco
Member Avatar
Troll Certified

snowfish
Jun 24 2013, 10:25 AM
94RHDRollerskate
Jun 23 2013, 11:03 PM
.
Did a compression test tonight, and not too thrilled with the results: 107-105-150

.
Tell me you forgot to hold wide open throttle! :'(
That's a 50% gap in compression, WOT or not...he's due for a rebuild.
Online Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

Coche Blanco
Jun 24 2013, 10:26 AM
snowfish
Jun 24 2013, 10:25 AM
94RHDRollerskate
Jun 23 2013, 11:03 PM
.
Did a compression test tonight, and not too thrilled with the results: 107-105-150

.
Tell me you forgot to hold wide open throttle! :'(
That's a 50% gap in compression, WOT or not...he's due for a rebuild.
.
Did not hold WOT. Only 126k too... bummer deal. Putting it on the 'to-do' list. Head job on the daugter's Protege comes first.

.
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

.
Commuted to work in front of and then behind this.... bad ass!

Posted Image

.
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

.
Dome Light/Clock came in the mail (Thx Kyle) yesterday. Need to research wiring info. Swifts apparently have the harness tucked at the bottom of the A-pillar. Doubt Metros do.

Posted Image

.
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

.
FINALLY... installed my Mr. Bill side skirts. :rocker

Posted Image

.
Posted Image

.
Started off by pulling the rear wheels and drilling the necessary holes...

.

Posted Image

I got a few plastic 'Christmas trees' and cut them down short, sprayed the ends with red paint and set them in the mounts where the actual fasteners will go. I set the skirt piece in place and pressed the painted tip tree to the side of the car. This left a red dot, so that I knew where to drill the fastener holes.

Posted Image

Posted Image

Posted Image

I then drilled the holes and installed the fasteners in. Installed the skirt halves and tightened up the screws. Then I drilled and installed screws across the bottom, and done.

.











Edited by 94RHDRollerskate, Jul 4 2013, 02:11 AM.
Offline Profile Quote Post Goto Top
 
aaronvincent
Member Avatar
Mr Mojo Risin'

Nice skirt :D
Where'd the dent in the fender come from?
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

aaronvincent
Jul 4 2013, 02:24 AM
Nice skirt :D
Where'd the dent in the fender come from?
.
Previous ownership. I removed the fender and popped it out. Installed the fender and while putting in the wheel well liner it popped back in.

.
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

.
I'm still trying to get my fender turn signals to work. They wouldn't light up unless I was pushing the wiring in with my hand. So, I removed the lens to find the bulb wasn't fully set into it's socket. Put it back together, and still no light. Looking at the socket itself, it's a weird design. I got these from Hong Kong, and they do take 194 bulbs, but they're not making good contact still. I may end up removing the center portion and grafting in an American 194 pigtail. Unless someone has an idea.

Posted Image

.
Offline Profile Quote Post Goto Top
 
Scoobs
Member Avatar
:D

Why dont you take a dremel, and notch that hole out for a connector like whats on the running lights.
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

Scoobs
Jul 4 2013, 11:43 AM
Why dont you take a dremel, and notch that hole out for a connector like whats on the running lights.
.
That's what I'm looking at doing Scoobs.

.
Offline Profile Quote Post Goto Top
 
Scoobs
Member Avatar
:D

Damn i want a set of skirts now :/ Lol
Offline Profile Quote Post Goto Top
 
94RHDRollerskate
Member Avatar
Forum Stud Muffin

Scoobs
Jul 4 2013, 05:12 PM
Damn i want a set of skirts now :/ Lol
.
You have a Swift... what happened to them? Damn, I want a hood.

.
Offline Profile Quote Post Goto Top
 
Scoobs
Member Avatar
:D

My swift didnt have any. Looks like they got tore off when po went into a curb or into somthin tearing the frame up lol
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
Go to Next Page
« Previous Topic · Project Forum · Next Topic »
Add Reply