Welcome Guest [Log In] [Register]
Posted ImageWelcome to the all new Geo Metro Forum. We hope you enjoy your visit.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are features you can't use and images you can't see. Registration is simple, fast, and completely free. If you're already a member please log in to your account to access all of our features:

Join our community!




Username:   Password:
Add Reply
I was only supposed to look at it; brought it home
Topic Started: Jul 15 2014, 10:32 AM (5,645 Views)
geogonfa
Member Avatar


Drove to Mineral Wells Tx. to repair a 98 3/5 hatch, easy fix ground problem, when I got done I was told about this Vert thats been sitting for seven years in which was just around the corner, apparently she was selling it on craigslist but no bites, lots of scams though...it has some body damage. no unibody damage...fuel tank was empty and no battery...new top, but not aligned correctly, and the body looks like someone painted it with a roller...but the Interior is pristine...serious amounts of potential... :D

Posted Image

Posted Image


Posted Image

Posted Image

Posted Image
Online Profile Quote Post Goto Top
 
Old Man


Looks like a good find.
Offline Profile Quote Post Goto Top
 
perfesser
Member Avatar
Elite Member - Former Metro owner

Honey, :wub: it followed me home. Can I keep it?? :lol :D :lol
Edited by perfesser, Jul 15 2014, 11:20 AM.
Offline Profile Quote Post Goto Top
 
snowfish
Member Avatar
Basic GearHead

Quote:
 
I was only supposed to look at it

You know better than that! :smackface Kind of like, "I'm only going to look at the puppies." :wub: :lol

Great find! :thumb Looks like some :gamerz and you're :drivin :cheers
Offline Profile Quote Post Goto Top
 
faygoninja


yet you took a car hauler............
Offline Profile Quote Post Goto Top
 
geogonfa
Member Avatar


actually, I brought the car hauler because I thought I might have to tow home the one I was going to repair...that's my story and I'm sticking to it...and I forgot to inform the wife of it yet...you know she's gonna tell me to fix it and flip it or I'm gonna have to sell one of the others... :hmm
Online Profile Quote Post Goto Top
 
faygoninja


Haha you control the gas but she is on the clutch :)
Offline Profile Quote Post Goto Top
 
Cobb
BANNED

I wouldnt mind a vert that was a 5 speed or at least drive one for a little while. :rocker
Offline Profile Quote Post Goto Top
 
Memphis metro


:thumb
Offline Profile Quote Post Goto Top
 
punkozuna
Member Avatar


You can never have too may verts!
Offline Profile Quote Post Goto Top
 
Metromightymouse
Member Avatar
Powdercoat Wizard

I know where that's at. Used to live in Weatherford and Azle and Springtown. Glad to see you made it out of the backwoods alive. :D
Online Profile Quote Post Goto Top
 
geogonfa
Member Avatar


Updates:
soaked the cylinders over night with PB Blaster, turned the crankshaft about eight turns with a ratchet and felt no resistance beyond the normal...
Installed some new spark plugs and hooked up a temporary Battery, no fuel pump humm, checked the pump circuit and found to have power to the pump...
dang it, bad pump...kinda expected it knowing it hasn't run for a long time.
hooked up a temporary fuel delivery set-up...cleaned all the grounds under the hood, and she started on the third crank
lifters pumped right up and no noises...I didn't run it for too long due to fuel delivery system.
pulled the tank, Fuel pump was locked up and tank was...well...hasn't been used for seven year sludge in bottom of tank...
gosh that smell is intense... :x
Battery tray was missing...bolts were still there...but no trace of the battery tray.
All four tires dry rotted to where you could actually see the belts...but they were almost new tires...so I'm gonna have to get some new rubber all around..
one thing that had me curious is that the radiator fan motor shroud is half missing...broken apart...
no other damage to be seen...front rad. support is straight and so is the rest of the front body
thorough body inspection and no rust to be found...always been a Texas Metro... :D
cleaning the fuel tank and replacing the fuel pump today so I can run the engine up to full temp than get some accurate compression numbers and look for any other possible problems...
:type
Online Profile Quote Post Goto Top
 
geogonfa
Member Avatar


Finally put the pump in and cleaned the tank...cleaned out the lines...new rubber lines, vacuum lines, and fuel filter...dang if it didn't start on the first try...no noises and smooth...let it run for a while and checked the compression numbers: 1-180, 2-185, 3-180... :D
found the dist. dripping, so I changed the gasket and put a "O" ring on the dist. no leaks so far...
Online Profile Quote Post Goto Top
 
econoboxer
Member Avatar
I am the one on the left.

Looks like a great start.
Offline Profile Quote Post Goto Top
 
whitetop
Member Avatar
I Can't Find My Tent...

Great find. It's hard to resist a vert when the opportunity arises. Have you told your wife yet? Did you hide it somewhere?
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
Go to Next Page
« Previous Topic · Project Forum · Next Topic »
Add Reply