Welcome Guest [Log In] [Register]
Posted ImageWelcome to the all new Geo Metro Forum. We hope you enjoy your visit.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are features you can't use and images you can't see. Registration is simple, fast, and completely free. If you're already a member please log in to your account to access all of our features:

Join our community!




Username:   Password:
Add Reply
Katie 97 1.3 auto; fix and keep or sell
Topic Started: May 14 2018, 11:44 PM (176 Views)
nwgeo


Well I am calling her Katie. I bought her from a gal who had it along time but the cost to pay the shop to change out the drive shaft was too much...I think the shop wanted around $500 to do the job.

I gave I think $450 for it I really tried to go $400 and probably could have got it for that but did not see that the headliner was bad. Battery is 5 years old but is holding a charge. Windscreen has a crack on the edge, and drivers side. Inside is fairly clean but for some food spots, dash is faded(you would think is was a 95) vent louvers most broken, factory AM/FM radio works, seat belts are good, no real tears in seats, window regulars work well, has AC :P , no rear hatch defrost :shake, 1st auto I have owned in a geo, clear coat is pealing, Starts and idles well, running a little warm...radiator may be plugged, have not heard the fan come on as yet. AC needs charged or more, Tires are pretty good shape no hub caps or wheel covers, pretty good dent in the rear quarter panel.

Engine is dusty oil leaks underneath but on top not bad, trans fluid is poor... need to change, will change oil and filter if needed.

Posted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted Image


Attached to this post:
Attachments: DSCN0712.jpg (188.32 KB)
Attachments: DSCN0713.jpg (193.21 KB)
Attachments: DSCN0714.jpg (184.25 KB)
Attachments: DSCN0715.jpg (188.21 KB)
Attachments: DSCN0716.jpg (149.49 KB)
Attachments: DSCN0717.jpg (182.03 KB)
Attachments: DSCN0718.jpg (195.56 KB)
Attachments: DSCN0719.jpg (188.56 KB)
Attachments: DSCN0720.jpg (194.52 KB)
Edited by nwgeo, May 15 2018, 12:14 AM.
Offline Profile Quote Post Goto Top
 
nwgeo


Oh, picture of the drive shaft I changed out after working a 12 hour day, took me maybe 40 minutes to change out.
Offline Profile Quote Post Goto Top
 
MR1 Kingsbury
Member Avatar
Exp. builder/rebuilder

that paint doesn't look all that bad in the pics...considering original age. I'm sure the peeling clearcoat makes it look hideous in spots, but I've seen a pretty nifty fix for worn CC on youtube/ you should search it out.
Offline Profile Quote Post Goto Top
 
smysmbrg
SteveO

I belive its the 98-2001 dashes that are the good ones that dont fade.
My 97 4/3 gets me about 30mpg runnin round the city delivering pizza and a 20 minute freeway commute.
I have seen the number 26 or less using the obd scanner on the freeway blasting 70mph or faster.
My 93 3/3 can get 36 mpg doing the same routine.
I Drive my autos once a week to work for a short shift to break up having to change gears all week on my all day shifts.
Online Profile Quote Post Goto Top
 
nwgeo


MR1 Kingsbury
May 15 2018, 05:17 AM
that paint doesn't look all that bad in the pics...considering original age. I'm sure the peeling clearcoat makes it look hideous in spots, but I've seen a pretty nifty fix for worn CC on youtube/ you should search it out.
Thanks MR1,

I will try and find that fix on youtube

Yeah, I thought it might be good to have a auto incase I or a friend gets banged up and shifting is a problem.


Interesting to me that it seems the automatics have painted bumpers but the 3/5s have non painted unless you paid extra?
Offline Profile Quote Post Goto Top
 
nwgeo


Come home after a long day... This is what I see greet me under the car I just worked on. Not just trans fluid but some antifreeze from under the water pump...can't see where the leak is for the anti freeze. Trans seal looks messed up.
Posted Image

Arugh, :smackface must have messed up the seal when installing the shaft. Do it all again, and a trip to Azone $5.59 for seal.

Okay got the old seal out...Did not think I messed it up but proof in the picture... seal was not crack or brittle.
Posted Image

And when working under there see the rad house bolts holding pipe are missing and one half of the bracket is gone and on further inspection the flex hose is against the trans and feels warn and floppy weak in that spot.
Posted Image
Posted Image

Running a little hot on idle fan came on and didn't seem to want to shut off... test drive... turned off the fan. :coffee

Check engine light is on.. :-/




Attached to this post:
Attachments: DSCN0721.jpg (193.49 KB)
Attachments: DSCN0722.jpg (143.03 KB)
Attachments: DSCN0723.jpg (168.93 KB)
Attachments: DSCN0724.jpg (174.13 KB)
Edited by nwgeo, May 15 2018, 11:46 PM.
Offline Profile Quote Post Goto Top
 
nwgeo


After work tonight...no leaks, yeah!! And removed foam from the head liner as needs new material and PO had already tore out the grey headliner material and just left the thin foam underneath.

Also, sprayed the dash with armor all... vents are ALL broken... why would someone break them all.


And got ready to clean out the very back and the spare tire was not right, so got the jack and lug wrench and tire all back in, board and carpet filler were in backward... fixed that, saw both nobs holding the rear seat are broken, need to get new ones.

Thanks all for tonight.
Edited by nwgeo, May 17 2018, 12:01 AM.
Offline Profile Quote Post Goto Top
 
ptcapboy


seems to be just a list of small things to fix i would think you got your money's worth at 450 dollars-I need a knob for my rear seat too, in the meantime I found a nut that fits on the end of the threaded shaft and am able to release the seat as designed-
Online Profile Quote Post Goto Top
 
nwgeo


Pictures of the paint, worse than you may have thought. Looked on utbe to see if could find a way to fix it...found a few different suggested ways to fix. :hmm

Looks to me like PO had something on the roof maybe a tarp, looks like lines across.
Posted Image
Posted Image
Attached to this post:
Attachments: DSCN0725.jpg (142.12 KB)
Attachments: DSCN0726.jpg (75.27 KB)
Edited by nwgeo, May 18 2018, 10:33 PM.
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Project Forum · Next Topic »
Add Reply